Timers not Syncing to Apple Watch


#1

Hi everyone,

I’ve been searching through the forums hoping to find an answer so I wouldn’t have to post a new topic, but I’m stumped.

I have Seconds Pro so I can make custom timers for my bootcamp classes and got a new iPhone. I set up the new phone from a backup and when opening the Seconds app, all of my custom timers are there. I synced my Apple Watch to the new phone and the Seconds app appeared on the watch just as it had with the old phone.

But when I go into the app on my watch, the only options I’m given are “Quick Timer”.

I’ve gone into the app on my phone, to the Apple Watch settings and clicked “Sync Timers Now”. Nothing happened. I uninstalled the app from the watch and reinstalled it. Nothing happened. Tried syncing again. Still nothing. So now I’m stumped.

Help?


#2

I don’t know what the issue is. Some people have reported this in the past. It often just works itself out after a bit of time. There really is nothing more I can do within the app.


#4

If you want to request a refund you will need to contact Apple directly. To do this please follow these steps:

  1. Visit http://reportaproblem.apple.com
  2. Sign in with your AppStore login.
  3. Navigate to Apps
  4. Search for the app in question then tap the Report a Problem button.
  5. Fill out the form and submit the request to Apple.

It will then be down to Apple’s discretion as to whether they issue the refund or not.


#5

And for the record, it’s not that I don’t care. It’s that I cannot fix problems I cannot recreate. The API for Apple Watch is pretty basic. There is a send data command. I use this to send the data. If it doesn’t get there it’s an Apple Watch issue.

I’ve never had this problem on any of my test devices. Other people have reported it but no one can provide a list of reproducible steps, and 9 times out of 10 it resolves itself without anyone doing anything.


#6

I feel like I gave you a pretty decent rundown of what I did:

Set up new iPhone from the iCloud backup of a different, old iPhone
Sync Apple Watch that had been connected to the old iPhone to the new iPhone
Try to access custom timers on Apple Watch, which is now connected to the new iPhone

I think maybe platomuppet is angry because you’re coming across as pretty flippant. We both gave you money for something that now does not work as we need it to and you’re just like “I don’t know, too bad, sorry”.

After getting the new phone, I kept the old phone as an iPod for music and games so I deleted a bunch of apps, including Seconds. If I go to reinstall Seconds, none of my custom timers are there either.


#7

Yes, but it has to be repeatable. If I cannot repeat it on demand there is no way to fix it as I have to being able to cause the problem and then verify my changes have resolved it. Just knowing what you did one time isn’t actually that helpful to me.

As I previously mentioned, there is one way to sync data to the watch. And of course, that’s the method I am using. It works for 99% of the users. Of the 1% (if it’s even that much) that is doesn’t, I’d say 99% of the time, reinstalling the Apple Watch app resolves the issue. For those that is still doesn’t work, I don’t know what the issue is. And there is no way of me finding out because I cannot replicate the issue on any of my hardware.

That’s right. Cloud syncing isn’t a feature of the app. You need to transfer the timers manually either by restoring an iCloud backup from the settings, or exporting them via email or AirDrop.